Motorsports Village
http://motorsportsvillage.com/forum/

Kens Dragster "Re_do"!
http://motorsportsvillage.com/forum/viewtopic.php?f=9&t=8373
Page 6 of 8

Author:  Ken0069 [ Sat Sep 10, 2011 7:34 pm ]
Post subject:  Re: Kens Dragster "Re_do"!

I guess he never tried to run a 12 year old tire on an 800 HP 1600lb car either! O:) Those tires will make some shake down runs to see where the finish line RPM is but they'll be gone before next season. Shame too as they only got 5 passes on'em from the US Nationals back in 1999.

Been trying to get in touch with Bubster to see what he thought about trying to bring them back with one of his "special" tire treatments but not having much luck. Maybe it's my breath? :-

Author:  Beretta [ Sat Sep 10, 2011 8:01 pm ]
Post subject:  Re: Kens Dragster "Re_do"!

Ken I have used this and does work well but you will need to coat them between rounds..
http://www.amazon.com/Formula-V-Tire-Tr ... B003FUY4BI

Author:  Ken0069 [ Sat Sep 10, 2011 9:16 pm ]
Post subject:  Re: Kens Dragster "Re_do"!

I've got some of that stuff on the shelf now but it never did do much for me? Maybe it's my breath! O:) =;

I remember Dennis saying that he used transmission fluid and something eles mixed to make them work again. :-k

Author:  us7race [ Sun Sep 11, 2011 7:21 am ]
Post subject:  Re: Kens Dragster "Re_do"!

Didn't realize they were that old... I thought you were getting on the brand.

Author:  Beretta [ Sun Sep 11, 2011 7:25 am ]
Post subject:  Re: Kens Dragster "Re_do"!

us7race wrote:
Didn't realize they were that old... I thought you were getting on the brand.


Yea me to #-o

Author:  Beretta [ Sun Sep 11, 2011 8:06 am ]
Post subject:  Re: Kens Dragster "Re_do"!

Ken0069 wrote:
Beretta wrote:
I like that Distributor =; =; .........


You probably like this fuel pump also then. =;

Image



It was my understanding that you never tryed the pump after you fix/repaired it..Or did I miss that somewhere??????? If it works for you it will have rock steady fuel pressure =; ...It always did for me till it just wore our or leaked at the most worst time it could... ](*,) ](*,) But they told me that's racing :-

Author:  Ken0069 [ Sun Sep 11, 2011 9:19 am ]
Post subject:  Re: Kens Dragster "Re_do"!

Barry I did test that pump here in the shop after I got it back together and it did work OK after it sat for a day or so with fuel in it, ie, it leaked at first but then stopped and yes, I still have that new seal kit you sent with it. Just didn't want to install that until I was actually going to use it on the car. I had it running dead head on the bypass at 10psig and it worked fine as far as I can tell but never did put it on the Camaro because of a lack of a suitable mounting place.

I won't run it right away on the dragster as I'll use the BLP belt drive like it was on the Camaro but I did want to make the mount and stuff to make it easier to swap it over just in case. If I run at Dinwiddie then I'll either have to install a fuel shutoff or go to an electric pump and since I've already got the pump, it just doesn't make sense to spend money on a bypass valve and cable. ;-)

Author:  Ken0069 [ Mon Sep 12, 2011 7:51 am ]
Post subject:  Re: Kens Dragster "Re_do"!

So yesterday I went looking for a scoop only to find that everything has gone up about $40 from what they were back 5 months ago? And the Obummer administration says that there's no inflation?? MY ASS! [-o< Obviously that asshole doesn't buy gas or groceries either!! Ennywho, the scoop that came with the car is the old style and it has some damage on it so I was looking to by one of the new style scoops to replace that one.

So does anyone know of a scoop seller that has decent prices on their stuff? :-k Or maybe a good "used" one?

Author:  gearhead1011 [ Mon Sep 12, 2011 8:28 am ]
Post subject:  Re: Kens Dragster "Re_do"!

I don't know what you've been pricing but have you tried Glasstek?
http://glasstek.com/

Author:  Ken0069 [ Mon Sep 12, 2011 12:26 pm ]
Post subject:  Re: Kens Dragster "Re_do"!

gearhead1011 wrote:
I don't know what you've been pricing but have you tried Glasstek?
http://glasstek.com/


Thanks Chuck but those prices are about the same as everyone else? Back when I got this car I could have bought one for around $240 and didn't because I didn't because I didn't need one right then and mslaton told he he'd seen them cheaper than that on fleabay. I guess I should have bought one anyway. Hind site is always 20/20 though.

Right about now, with all the money I've already spent in the past few months I think I'll just sand and prime the one I've already got and try to get through the rest of the season. That way I'll be able to pay about $350 for one next spring! :- Hopefully the Camaro will sell after the first of the year and I'll have more operating capital. :-({|=

Author:  Ken0069 [ Mon Sep 12, 2011 8:08 pm ]
Post subject:  Re: Kens Dragster "Re_do"!

Well, today I got the coil mounted, the oil filter system plumbed including the accumulator and I got the throttle cable installed and mounted. I even ran the engine on the starter a few times and pumped the converter and the engine oil filter full of oil cuz both levels went down.

Got the stuff to plumb the radiator and will get on that tomorrow. Should be done by Wednesday I hope. Then I can get back on the few things the trailer still needs.

Image

Author:  krazy55ken [ Mon Sep 12, 2011 8:14 pm ]
Post subject:  Re: Kens Dragster "Re_do"!

I see whats wrong now Ken there is not enought bolt holes in the vavle covers. LOL

Author:  Ken0069 [ Mon Sep 12, 2011 9:21 pm ]
Post subject:  Re: Kens Dragster "Re_do"!

krazy55ken wrote:
I see whats wrong now Ken there is not enought bolt holes in the vavle covers. LOL


I hear what you're saying Kenny but I do want to run quicker than 5.20s! O:) =;

Author:  krazy55ken [ Mon Sep 12, 2011 9:46 pm ]
Post subject:  Re: Kens Dragster "Re_do"!

Now thats funny I dont care who you are.. =D>

Author:  Ken0069 [ Tue Sep 13, 2011 7:39 pm ]
Post subject:  Re: Kens Dragster "Re_do"!

Well, I worked on the cooling system today and got that installed, plumbed, filled and purged the air out so that's another piece of the puzzle that's done. I really don't like these over the tranny radiator mount deals but as I said before, with a 225" car I'm pretty limited on places to put one.

Here's a couple of pics of that and notice that I used 1" hose instead of the usual -8 half inch stuff.

Image

Image

I guess tomorrow I'll start working on the trailer again.

Page 6 of 8 All times are UTC - 5 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/