Login    Forum    Search    FAQ

Board index » Racing Forum » Drive Train, Suspension and Brakes




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Confused again??!!
 Post Posted: Tue May 12, 2009 10:45 am 
Offline
User avatar

Joined: Wed Dec 06, 2006 9:24 pm
Posts: 5071
Location: Elizabethtown, KY
We have solid motor mounts and a urathane trans mount. Several people have been telling me to go solid all the way around. I'm sure this has been covered before. I can't run a mid plate in NMC so that is out of the question. The car doesn't twist like it used too.

_________________
Steve

6.7772 @ 101.51 1/8th 10.747 @ 122.24 1/4

Image


Top 
 Profile  
 
 Post subject: Re: Confused again??!!
 Post Posted: Tue May 12, 2009 10:57 am 
Offline
User avatar

Joined: Mon Oct 29, 2007 7:07 pm
Posts: 1422
Location: Florida
Don't. Some get away with it, but if you have any twist in the chassis you will break something, usually a bell housing.


Top 
 Profile  
 
 Post subject: Re: Confused again??!!
 Post Posted: Tue May 12, 2009 5:21 pm 
Offline
User avatar

Joined: Wed Apr 19, 2006 8:20 pm
Posts: 5852
Location: N.J.
Steve I would try a stock GM trans mount and just keep an eye on it....You also may want to get a set of later gm mounts for the engine as they have stops on them but I don't think they will last to long. Or just replace the case every few weekends O:) O:) ......I have seen ultra bells crack :-s :-s

_________________
Image
running E85
Best ET 8.07
Best MPH 170.71
Barry


Top 
 Profile  
 
 Post subject: Re: Confused again??!!
 Post Posted: Tue May 12, 2009 5:55 pm 
Offline
User avatar

Joined: Wed Dec 06, 2006 9:24 pm
Posts: 5071
Location: Elizabethtown, KY
Thanks guys. we all seem to agree solid motor , rubber trans. =; I still think I had it in a bind when I put the motor in. Thanks again.

_________________
Steve

6.7772 @ 101.51 1/8th 10.747 @ 122.24 1/4

Image


Top 
 Profile  
 
 Post subject: Re: Confused again??!!
 Post Posted: Tue May 12, 2009 6:24 pm 
Offline
User avatar

Joined: Mon Oct 29, 2007 7:07 pm
Posts: 1422
Location: Florida
I did something years ago on my Chevelle, I used the thin "Plumbers Tape", the metal strap with holes around the mount and ran a bolt horizontally through the steel. Still allowed flex but kept it from separating too much.


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 5 posts ] 

Board index » Racing Forum » Drive Train, Suspension and Brakes


Who is online

Users browsing this forum: No registered users and 4 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron