Login    Forum    Search    FAQ

Board index » Racing Forum » Show Off Your Stuff!




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: my old new ride
 Post Posted: Wed Jan 30, 2013 2:50 pm 
Offline

Joined: Mon Jan 28, 2013 1:55 pm
Posts: 5
This is my first car 66 cutlass paid $40 for it back in 1977 had house carpet in it and was painted skyblue with a paint brush had a 330 in it that didnt last long so I found a pontiac 350 for $ 20 and dropped that in it and I went through 4 more of those but moved up to a 400 got married in 1980 and parked it till 3 yrs ago if you look at my attachment you can see work in progress. It now has a 468 stroker solid roller 48 heads, 12bolt 331gears, muncie 4 spd, Ram clutch,dougs headers with cutouts, 14" mickeys , lakewood shield changed it to front power disk braks did the bodywork and sprayed the candy red myself buddy let me use his spray booth that was nice. My son Aaron did the rat fink style cartoon on the hood. Changing it over to e 85 and sometime I want to take it to the track its been alot of fun seeing it go together with the oldschool look even got a picture of it in front of my old school thats closed now

_________________
http://s1059.beta.photobucket.com/user/cutlasstony/media/164_zps02ec6a9a.jpg.html?sort=3&o=16


Top 
 Profile  
 
 Post subject: Re: my old new ride
 Post Posted: Wed Jan 30, 2013 6:36 pm 
Offline
Site Admin
User avatar

Joined: Tue Apr 18, 2006 6:38 am
Posts: 11808
Location: Coming At Ya!
My first Olds was a 1956 two door sedan. I raced it back in the 1960s when they still had a "Flag Man" on the starting line. It ran E/SA and was a turd. =;

My second Olds was a 1967 "442" that was a 400 ci with a 4 speed. I didn't keep that one long before I traded it in on another "442" but that one was a 1968 W-30 car.

After "numerous" engine failures I finally traded the W-30 car in on a 1971 Toyota pickup truck after I got married and couldn't afford it any more. That car ran 12.90s @ 106 MPH in the quarter mile.

I had a lot of fun with that car though and still have a picture of it on my other website.

Oddly enough, I won more money and more races with a 1963 VW than I have with any other car I've ever owned! Sometimes slow is better, hey!

But yeah, looks like you did a fine job on the restoration!! ;-)


Top 
 Profile  
 
 Post subject: Re: my old new ride
 Post Posted: Wed Jan 30, 2013 9:13 pm 
Offline

Joined: Mon Apr 30, 2012 10:01 pm
Posts: 140
Love the paint. The Color's great. The reflection down the side looks real good. No waves.


Top 
 Profile  
 
 Post subject: Re: my old new ride
 Post Posted: Wed Jan 30, 2013 9:26 pm 
Offline
User avatar

Joined: Wed Dec 06, 2006 9:24 pm
Posts: 5074
Location: Elizabethtown, KY
Great work on the car it is BadA$$ \:D/ \:D/ \:D/

_________________
Steve

6.7772 @ 101.51 1/8th 10.747 @ 122.24 1/4

Image


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 4 posts ] 

Board index » Racing Forum » Show Off Your Stuff!


Who is online

Users browsing this forum: No registered users and 1 guest

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to: